Bir Sütunu Yaşa Göre Gruplandırma

Yaşlarla çalışırken, özellikle demografik veriler için yaşları kategorilere ayırmak yaygındır. Her yaştaki istatistikleri raporlamak yerine, insanlar normalde sonuçları '20 yaşından küçük', '20 ila 30 yaş arası', '30 ila 40 yaş arası' vb. yaş gruplarında rapor eder.

Doğum tarihiniz varsa, yaş yardımcı sütununu (veya yaş yardımcı sütununu) almak için aşağıdaki formülü kullanarak bugün veya belirli bir tarih (ör. yıldaki yaşları nasıl hesaplayacağınızı kontrol edin ):

=TARİHLİ(B2,TARİH(2015,9,30),'Y')



B2, doğum tarihi olan hücredir.

1. Excel 2019'a sahipseniz, EĞER işlevi yaşları farklı kategorilere ayırmak için aşağıdaki formülle:

– 20 yaşından küçük
– 20 ila 30 yaş arası
– 30 ila 40 yaş arası
– 40 ila 50 yaş arası
– 50 yaşından büyük

=IFS(C2<20, '20 yaşından küçük', AND(C2>=20,C2<30),'20 ila 30 yaşında',AND(C2>=30,C2<40),'30 ila 40 yaşında',AND(C2>=40,C2<=50),'40 ila 50 yaşında',C2>50,'50 yaşından büyük')

C2'nin B2'deki doğum tarihine göre hesaplanan yaş olduğu yerde, yardımcı sütun olmasını istemiyorsanız, C2'yi =DATEDIF(B2,TARİH(2015,9,30),'Y' formülüyle değiştirebilirsiniz. ).

2. Excel 2016 ve önceki sürümlere sahipseniz, IFS İşlevini kullanamazsınız, ancak EĞER işlevi aşağıdaki formülle:

=EĞER(C2<20,'20 yaşından küçük', EĞER(VE(C2>=20,C2<30),'20 ila 30 yaşında',EĞER(VE(C2>=30,C2<40) ,'30 ila 40 yaşında',IF(AND(C2>=40,C2<=50),'40 ila 50 yaşında',IF(C2>50,'50 yaşından büyük')))))

Burada C2, B2'deki doğum tarihine göre hesaplanan yaştır.

İki formül aynı sonuçlarla gelir, ancak IFS işlevini Excel 2016'da ve önceki bir sürümde kullanamazsınız.

Yaşları aya göre gruplamak istiyorsanız, lütfen kontrol edin aylarda yaş nasıl hesaplanır , ardından yaşları kategorilere ayırmak için yukarıdaki formülü kullanın.